This incident has been resolved. Thank you for your patience.
Posted May 13, 2022 - 13:14 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 13, 2022 - 10:44 EDT
Identified
We are investigating reports of latency with CPX xChange (https://cpxchange.com/). We are actively researching and will provide more information shortly.