CPX xChange Unavailable

Incident Report for CPX

Resolved

This incident has been resolved.
Posted Jun 01, 2020 - 21:20 EDT

Monitoring

The availability/latency issues we were experiencing with CPX (https://cpxchange.com/) appear to be resolved. We are conducting a final round of testing and monitoring the systems at this time. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Priority Payment Systems, and we are making continuous improvements to make our systems better.
Posted Jun 01, 2020 - 20:37 EDT

Update

We are currently going through some testing of the potential resolution. Thank you for your continued patience.
Posted Jun 01, 2020 - 19:56 EDT

Update

Thank you for your continued patience, have identified the issue and we are working on a resolution.
Posted Jun 01, 2020 - 16:34 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 01, 2020 - 15:59 EDT

Identified

Thank you for your patience, have identified the issue and we are working on a resolution.
Posted Jun 01, 2020 - 15:27 EDT

Update

We are investigating reports that CPX xChange (https://cpxchange.com/) is unavailable. We are actively researching and will provide more information shortly.
Posted Jun 01, 2020 - 14:56 EDT

Investigating

We are investigating reports that CPX xChange (https://cpxchange.com/) is unavailable. We are actively researching and will provide more information shortly.
Posted Jun 01, 2020 - 14:20 EDT
This incident affected: CPXchange.