CPX xChange unavailable

Incident Report for CPX

Resolved

This incident has been resolved.
Posted Mar 28, 2019 - 10:26 EDT

Investigating

We are investigating reports that CPX xChange (https://cpxchange.com/) is unavailable. We are actively researching and will provide more information shortly.
Posted Mar 28, 2019 - 09:56 EDT
This incident affected: CPXchange.