CPX xChange delayed reporting

Incident Report for CPX

Resolved

This incident has been resolved.
Posted Nov 08, 2019 - 18:08 EST

Update

We are continuing to investigate this issue.
Posted Nov 08, 2019 - 17:52 EST

Investigating

We are currently investigating why many reports in CPX xChange (https://cpxchange.com/) are not showing updated data. We are actively researching and will provide more information shortly.
Posted Nov 08, 2019 - 17:29 EST
This incident affected: CPXchange.